First Last Prev Next    No search results available
Details
: Thunderbird 57 hangs on start with SmartTemplate4 enabled
Bug#: 26446
: smarttemplate4
: General
Status: RESOLVED
Resolution: DUPLICATE of bug 26494
: PC
: Windows NT
: unspecified
: P2
: major
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Axel Grude <axel.grude@gmail.com>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
1.5 prerelease 60 (389.93 KB, application/x-xpinstall)
2017-11-18 13:31, Axel Grude
no flags Details
1.5 prerelease 66 (390.02 KB, application/x-xpinstall)
2017-11-24 17:56, Axel Grude
no flags Details
1.5 prerelease 69 (390.01 KB, application/x-xpinstall)
2017-11-25 13:03, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2017-11-18 10:25
Thunderbird 57 starts up but doesn't show its main window so needs to be killed
with Task Manager when SmartTeemplate4 is enabled. There are many other XUL
based
addons that exhibit the same behaviors. See also Thunderbird  Bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1417209

I am working with the helpful guys at maildev (Joerg Knobloch etc.) to get this
resolved.
------- Comment #1 From Axel Grude 2017-11-18 10:31:25 -------
I have done some fixes regarding the version string appended to the javascript
including in XUL but Thunderbird still hangs when I try to open the
SmartTemplate4 options window. I cannot see any error messages / exceptions and
the onLoad() function of settings.xul

SmartTemplate4.Settings.onLoad()

is never reached.
------- Comment #2 From Axel Grude 2017-11-18 13:31:06 -------
Created an attachment (id=8341) [details]
1.5 prerelease 60

This version will allow Thunderbird to start, and seems to "partly" work.
However the options dialog will still freze Thunderbird.
------- Comment #3 From Marco 2017-11-18 21:54:49 -------
Hello
Does not work on TB 58.0a1 (2017-11-09)
----
Sorry, I use an online translator French / English
------- Comment #4 From Axel Grude 2017-11-24 17:56:27 -------
Created an attachment (id=8348) [details]
1.5 prerelease 66

Added some fixes for Thunderbird 57 b2
------- Comment #5 From Axel Grude 2017-11-25 13:03:28 -------
Created an attachment (id=8350) [details]
1.5 prerelease 69

fixed binding of load function in settings
------- Comment #6 From Marco 2017-11-29 01:20:49 -------
Work fine on TB 58b1 do not work's on TB Nightly 59 (write mail smartemplate is
empty)
------- Comment #7 From Thanos 2018-03-09 00:05:01 -------
Hello 
Any chance for thunderbird 59 compatibility?
dialog box appears corrupted and no changes can be applied.
------- Comment #8 From Axel Grude 2018-03-09 00:30:38 -------
(In reply to comment #7)
> Hello 
> Any chance for thunderbird 59 compatibility?
> dialog box appears corrupted and no changes can be applied.
> 

Yeah Tb 59 and later are handled in [Bug 26494]

https://www.mozdev.org/bugs/show_bug.cgi?id=26494
"ESR 2018 readiness - Make SmartTemplate4 compatible with Tb 60"

There is a new version that covers the new Thunderbird compatibility.
------- Comment #9 From Axel Grude 2018-03-09 00:34:06 -------
Marking as duplicate to the ESE bug which handles all ESE 2018 related issues.

*** This bug has been marked as a duplicate of bug 26494 ***
------- Comment #10 From Thanos 2018-03-10 06:13:05 -------

(In reply to comment #8)
> (In reply to comment #7)
> > Hello 
> > Any chance for thunderbird 59 compatibility?
> > dialog box appears corrupted and no changes can be applied.
> > 
> 
> Yeah Tb 59 and later are handled in [Bug 26494]
> 
> https://www.mozdev.org/bugs/show_bug.cgi?id=26494
> "ESR 2018 readiness - Make SmartTemplate4 compatible with Tb 60"
> 
> There is a new version that covers the new Thunderbird compatibility.
> 
Many thanks!

First Last Prev Next    No search results available