First Last Prev Next    No search results available
Details
: Renaming or Moving Folder causes orphaned Tabs on Subfolders
Bug#: 26095
: QuickFolders
: General
Status: RESOLVED
Resolution: FIXED
: PC
: Windows NT
: unspecified
: P2
: major
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Yango Pohl <yango.pohl@zahnunfall.de>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
4.2.2 prerelease 17 (660.39 KB, application/x-xpinstall)
2015-10-19 06:10, Axel Grude
no flags Details
4.2.2 prerelease 20 (660.53 KB, application/x-xpinstall)
2015-10-19 11:14, Axel Grude
no flags Details
4.2.2 prerelease 25 (660.93 KB, application/x-xpinstall)
2015-10-19 12:30, Axel Grude
no flags Details
4.2.2 prerelease 28 (660.98 KB, application/x-xpinstall)
2015-10-19 12:56, Axel Grude
no flags Details
4.2.2 prerelease 34 (661.07 KB, application/x-xpinstall)
2015-10-20 04:17, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2015-10-17 19:05
Hi, Axel,
renaming a folder causes the loss of the link between qf-tabs to subfolders of
that renamed folder - whether using the tree or the qf-commands. ("Dies ist ein
Tab der auf ein ung├╝ltiges Verzeichnis verweist").
------- Comment #1 From Axel Grude 2015-10-18 03:35:45 -------
I think that is a good catch - I may have looked at this before but it is not
impossible to fix as I have a global folder listener in place. It may only look
at the tabs themselves (and not the children) for fixing the URLs, so
definitely a P2 with major severity. I will see what I can do on the quick to
fix this.
------- Comment #2 From Axel Grude 2015-10-18 04:23:37 -------
(In reply to comment #1)
> I think that is a good catch - I may have looked at this before but it is not
> impossible to fix as I have a global folder listener in place. It may only look
> at the tabs themselves (and not the children) for fixing the URLs, so
> definitely a P2 with major severity. I will see what I can do on the quick to
> fix this.
> 

I found one additional problem - once prompted for deleting the tab, if the
user accepts it, the tab is not immediately removed from the QuickFolders
toolbar, which leads to even more confusion, so I am going to address this as
well as part of this bugfix.
------- Comment #3 From Axel Grude 2015-10-18 04:39:11 -------
(In reply to comment #2)
> (In reply to comment #1)
> > I think that is a good catch - I may have looked at this before but it is not
> > impossible to fix as I have a global folder listener in place. It may only look
> > at the tabs themselves (and not the children) for fixing the URLs, so
> > definitely a P2 with major severity. I will see what I can do on the quick to
> > fix this.
> > 
> 
> I found one additional problem - once prompted for deleting the tab, if the
> user accepts it, the tab is not immediately removed from the QuickFolders
> toolbar, which leads to even more confusion, so I am going to address this as
> well as part of this bugfix.
> 
I am encountering another problem on my test account (on Tb 42 beta 2) -
apparently the IMAP synchronization with gmail doesn't update the folder tree
immediately if I rename a folder from the folder tree - I have to restart
Thunderbird. This is not good as I am not getting the rename event during the
session. It might be caused by my slow internet connection or the fact that the
folder tree is under the [Gmail] folder. In any case that's make testing the
fix (on IMAP) difficult. I will try to test it on POP3 first...
------- Comment #4 From Axel Grude 2015-10-19 06:10:32 -------
Created an attachment (id=8112) [details]
4.2.2 prerelease 17

This version addresses the bug in Thunderbird (not tested in Postbox /
SeaMonkey which might be different). I have replaced the renameFolders function
with an identical one within QuickFolders which takes a note of the URI and new
folder name. There is still a problem (I suspect it is a bug in Thunderbird /
gmail) in that the rename does not reflect immediately in the folder tree for
[Gmail] subfolders. The only valid way I found to update the tree was
restarting Thunderbird

This means that although the fixed version does correct tabs pointing to
subfolders correctly you can still get the (now incorrect) error message on
IMAP saying "this tab points to an incorrect folder location" even thought the
folder location exists on the remote server (and it will be correct after
Thunderbird restarts). Not to sure how to address this yet as it appears to be
an IMAP / Sync problem. It might be best to disable the validation routine on
these tabs after they were affected by the rename (even though the tree
navigation will be broken until the forced re-sync)
------- Comment #5 From Axel Grude 2015-10-19 11:14:41 -------
Created an attachment (id=8113) [details]
4.2.2 prerelease 20

So this version deals with the problem of the Thunderbird disconnect to the
IMAP server by flagging all Tabs with modified URIs so that they do not trigger
the path validation routine until the next restart. 

They will also then not try to open the (invalid) folder unless it exists
avoiding further pollution of the error log.

Testing in IMAP: you can still select the subfolders but they do not open in
the tree if the tree is "disconnected" from the folders on the IMAP server.

Testing on Local Folders: subfolders of renamed folder are working without
problems.

Testing on POP: subfolders of renamed folder are working without problems.

Customized Icons: may stop working during session but should show on next
reload.
------- Comment #6 From Axel Grude 2015-10-19 12:30:48 -------
Created an attachment (id=8114) [details]
4.2.2 prerelease 25

This one works in Postbox as well.

Also if you use special characters (such as ' ' Space) they will be less likely
to break the URI. Apparently there is some encoding going on for generating a
safe filename (this is done deep in the C code, I am using the somehwat mundate
encodeURIComponent() function for this so it might not be 100% correct when
using arcane characters such as Kanji or eastern european languages. To be
tested...
------- Comment #7 From Axel Grude 2015-10-19 12:56:20 -------
Created an attachment (id=8115) [details]
4.2.2 prerelease 28

SeaMonkey compatible version...

tested in Postbox 4.0.6 + SeaMonkey 2.38
------- Comment #8 From Axel Grude 2015-10-20 01:28:14 -------
FYI:

https://bugzilla.mozilla.org/show_bug.cgi?id=1120361

IMAP: after folder rename or move messages couldn't be opened anymore until
restart - works in an older TB version (< 31)

Please follow that bug to see when the folder tree synchronization is fixed in
Thunderbird.
------- Comment #9 From Axel Grude 2015-10-20 04:17:49 -------
Created an attachment (id=8116) [details]
4.2.2 prerelease 34

Yet another improvement.

We had the same problem when _moving_ folders within the tree (on the same
account) - this would break connections of tabs pointing to subfolders. This
version addresses this issue as well.

Test case (SeaMonkey):

Create the following folder / subfolder structure (children indented)

Read
Quickfolders
  test1
    Bug 1

create QuickFolders tabs for test1 and Bug 1

Move "test1" into the folder "Read", resulting in this structure:

Read
  test1
    Bug 1
Quickfolders

=> Tabs for test1 and Bug 1 still work.
Tested in Sm + Tb. To do: test in Postbox 4
------- Comment #10 From Axel Grude 2015-10-31 03:45:57 -------
Released in version 4.2.2, 20/11/2015

First Last Prev Next    No search results available