First Last Prev Next    No search results available
Details
: Customizable Icons in Foldertree
Bug#: 25708
: QuickFolders
: General
Status: RESOLVED
Resolution: FIXED
: PC
: Windows NT
: unspecified
: P3
: enhancement
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: bill <bill@billcooke.co.uk>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
3.15 prerelease 3 (508.19 KB, application/x-xpinstall)
2014-02-22 00:48, Axel Grude
no flags Details
3.15 prerelease 4 (508.45 KB, application/x-xpinstall)
2014-02-22 16:12, Axel Grude
no flags Details
3.15 prerelease 8 (508.60 KB, application/x-xpinstall)
2014-02-23 21:22, Axel Grude
no flags Details
16px² Icon Library (854.64 KB, application/x-zip-compressed)
2014-02-27 09:06, Axel Grude
no flags Details
3.15 prerelease 154 (519.45 KB, application/x-xpinstall)
2014-03-12 22:00, Axel Grude
no flags Details
Icon (66.06 KB, image/x-icon)
2014-03-13 16:52, bill
no flags Details
3.15 prerelease 316 (520.14 KB, application/x-xpinstall)
2014-08-14 04:22, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2014-02-17 17:54
It would be very useful if you could add the ability to change the Thunderbird
folder icons in the folder tree. I mean assign different icons to individual 
folders, not just a global change and not just the ones TB has already assigned
- all the new folders I create. This would really help navigation when there
are more than a few folders.
------- Comment #1 From Axel Grude 2014-02-17 18:25:07 -------
Agreed. My first goal would be to tie this in with the new Tab Icons (so that
we have an interface and storage structure to start from). Bear in mind that is
actually difficult to modify individual contents of a treeview like the folder
tree, so this is probably going to take a while to even come up with some
prototypes. I hope more people subscribe to this bug to show that there is a
broader interest.
------- Comment #2 From Axel Grude 2014-02-21 23:34:26 -------
I am currently working on this feature, most of the nuts+bolts coding is done
but I might change the way I store the icons (at the moment they are stored in
the configuration database, but this is not ideal as the list can get rather
long)
------- Comment #3 From Axel Grude 2014-02-22 00:48:34 -------
Created an attachment (id=7790) [details]
3.15 prerelease 3

First Prototype which supports icons on the folder tree. You can set the icon
both from the folder tree popup and from any QuickFolders tab > QuickFolders
Command. Submenu items and recent folder menu items will also be styled with
the same icons for consistency. It is recommended to use 16px² images
(preferably png, gif or ico). Multi-image-maps are currently not supported. The
custom icons can be removed with the "Remove Icon" command.

It is also possible to override special folders such as Inbox, Sent and even
account images - don't come running if you confuse yourself. The icons do not
currently support special status glyphs like the "New Mail Star" etc. (Might be
considered for future versions)

NOTE: the storage method of the icons is subject to change so you might have to
recreate your icons when this goes into release. If I go for storing the icon
references in a file then I will provide instructions on how to import the old
settings. 

The current storage of the file locations is in configuration database under
the key:
extensions.quickfolders.folderIcons

NOTE2: If you already have defined icons for the QuickFolder tabs, you must
create them again to update the folder tree, as these are stored separately but
must be defined at the same time (from now on)
------- Comment #4 From Axel Grude 2014-02-22 16:12:20 -------
Created an attachment (id=7792) [details]
3.15 prerelease 4

Adding support for displaying the icon in the current folder bar and a button
to set the icon from there
------- Comment #5 From Axel Grude 2014-02-23 21:20:55 -------
*** Bug 25645 has been marked as a duplicate of this bug. ***
------- Comment #6 From Axel Grude 2014-02-23 21:22:57 -------
Created an attachment (id=7793) [details]
3.15 prerelease 8

Here is a version that manages to restore the icons dictionary without storing
all that data in about:config; instead the information is taken directly from
the folders, so this should perform better in the long run.
------- Comment #7 From bill 2014-02-25 18:37:03 -------
Many thanks for the new version. It works well for me. One thing I wasn't
expecting. You have to choose the icons carefully. I have a collection but many
do not display well at such a small size. I wasn't expecting that.  The icons
supplied by yourself work well, probably because they were designed to be
small. Like you, I don't put icons on all my folders, only ones I want to find
frequently. I am presently rebuilding my computer and I am looking forward to
setting Thunderbird up with these icons when I reinstall it.
Well done. Good Job.
Best wishes

Bill
------- Comment #8 From Axel Grude 2014-02-25 19:50:57 -------
(In reply to comment #7)
> Many thanks for the new version. It works well for me. One thing I wasn't
> expecting. You have to choose the icons carefully. I have a collection but many
> do not display well at such a small size. I wasn't expecting that. 
Yes I should have probably added that you need 16px² images - anything else
probably won't look too well as the folder isn't really designed for very much
bigger ones. Everything bigger than that will currently be rigorously cut off.
We could probably build in a rule for the size but it is going to be much
harder if you want different sizes for each icon - it might even require some
user intervention.

This also makes me think that I cannot deliver this feature without at least
pointing my users to a place where they can download a set of (free) icons,
which in itself might have some juristic pitfalls attached.

One thing that is quite nicely suited are the so-called "favicons" which are
(usually 16px²) images utilized by web pages; I can only supply these as per
"fair use" (anybody is able to download them themselves as well by going to the
site and following a few steps). If there are any particular website icons you
think are essential, please make a list and attach it to this bug and I can see
whether I can source them for the release version.

>  The icons supplied by yourself work well, probably because they were designed to be small. 

most of the small icons in the folders
counter, glyphs, mail, music, office, smileys and users are from the icon set
"fugue" by Yusuke Kamiyamane and are released under Creative Commons.

my own icons in the quickfolders folder are partly based on his and partly on
the "crystal" icon set by Everaldo. There might also be one or two that came
straight from the (older) default skin of Thunderbird. 

I do not supply monochrome icons as I do not find them terribly useful -
something colorful is usually easier to spot.

> Like you, I don't put icons on all my folders, only ones I want to find
> frequently. I am presently rebuilding my computer and I am looking forward to
> setting Thunderbird up with these icons when I reinstall it.

Yes I think it is more useful to just accentuate the most important folders so
they can easily be found. Also I think the icons need to be consistent across
most of the main interfaces, the folder tree, QuickFolders tabs and the
subfolder popups. I think I have done a good job so far, but probably needs to
do a little performance tweaking.
------- Comment #9 From bill 2014-02-26 17:47:25 -------
(In reply to comment #8)
> (In reply to comment #7)
> 
Hi
Many thanks for the detailed reply. Thanks for all the effort.

On 26/02/2014 03:50, bugzilla-daemon@mozdev.mozdev.org wrote:
> https://www.mozdev.org/bugs/show_bug.cgi?id=25708
>
> --- Comment #8 from Axel Grude <axel.grude@gmail.com&ggt;  2014-02-25 19:50:57 ---
> (In reply to comment #7)
>> Many thanks for the new version. It works well for me. One thing I wasn't
>> expecting. You have to choose the icons carefully. I have a collection but many
>> do not display well at such a small size. I wasn't expecting that. 
> Yes I should have probably added that you need 16px² images - anything else
> probably won't look too well as the folder isn't really designed for very much
> bigger ones. Everything bigger than that will currently be rigorously cut off.
> We could probably build in a rule for the size but it is going to be much
> harder if you want different sizes for each icon - it might even require some
> user intervention.
>
> This also makes me think that I cannot deliver this feature without at least
> pointing my users to a place where they can download a set of (free) icons,
> which in itself might have some juristic pitfalls attached.

Please do not let this make you decide to pull the feature. Simply point out
the restriction to users and allow us to choose, even if we mess it up. Perhaps
a "reset to default" option could be included. I did a Google search for  "free
16 x 16 icons" and there seems to be a lot. I haven't tried them yet as I am
waiting for the rebuild. This page looked interesting    Small-icons  This will
be a change for me as I usually look for large icons.
>
> One thing that is quite nicely suited are the so-called "favicons" which are
> (usually 16px²) images utilized by web pages; I can only supply these as per
> "fair use" (anybody is able to download them themselves as well by going to the
> site and following a few steps). If there are any particular website icons you
> think are essential, please make a list and attach it to this bug and I can see
> whether I can source them for the release version.
The problem here is that each use will have their own set of "essential" icons.
E.G. I want "garden ", "Consumer groups" and "Cricket club".  I don't think
many people will need those.
>
>>  The icons supplied by yourself work well, probably because they were designed to be small. 
>>
>> most of the small icons in the folders
>> counter, glyphs, mail, music, office, smileys and users are from the icon set
>> "fugue" by Yusuke Kamiyamane and are released under Creative Commons.
>>
>> my own icons in the quickfolders folder are partly based on his and partly on
>> the "crystal" icon set by Everaldo. There might also be one or two that came
>> straight from the (older) default skin of Thunderbird. 

>> Have you thought of including a link to one of the free icon editors?
>> I do not supply monochrome icons as I do not find them terribly useful -
>> something colorful is usually easier to spot.
>>  Yes I tried some of these and they all look just the same at this scale.
>> Like you, I don't put icons on all my folders, only ones I want to find
>> frequently. I am presently rebuilding my computer and I am looking forward to
>> setting Thunderbird up with these icons when I reinstall it.
> Yes I think it is more useful to just accentuate the most important folders so
> they can easily be found. Also I think the icons need to be consistent across
> most of the main interfaces, the folder tree, QuickFolders tabs and the
> subfolder popups. I think I have done a good job so far, but probably needs to
> do a little performance tweaking.
> I agree - you have done a good job here.
Best wishes

Bill
>



This email has been scanned by Netintelligence
http://www.netintelligence.com/email
------- Comment #10 From Axel Grude 2014-02-27 09:06:43 -------
Created an attachment (id=7799) [details]
16px² Icon Library

A selection of Open Source and Public Domain Icons for use with the folder tree

No rights of distribution or ownership can be inferred; these are strictly used
under fair use policy - if you find an icon that is copyrighted please notify
me and I will remove it.

Crystal Clear Icons - by Everaldo under LGPL
Fugue Icon Set - by Yusuke Kamiyamane under Creative Commons
Flags - Open Icon Library on sourceforge.net
------- Comment #11 From Axel Grude 2014-03-12 22:00:58 -------
Created an attachment (id=7807) [details]
3.15 prerelease 154

Here is a more mature version which supersedes prerelease 8. Please test
relentlessly :)
------- Comment #12 From bill 2014-03-13 16:52:59 -------
Created an attachment (id=7809) [details]
Icon

Hi Axel
Many thanks for the new version. I will let you know if there are any problems.
One thing I have noticed before is that some icons do not show up. Instead the
icon for the folder disappears leaving a blank space
Attached is a copy of one icon which behaves like this.
This change to Quick Folders has made it incompatible with the Colour Folders
add on but that is not surprising as they both address the same area.

Hope this is useful 
------- Comment #13 From Axel Grude 2014-03-13 18:20:44 -------
(In reply to comment #12)
> Created an attachment (id=7809) [details] [details]
> Icon
> 
> Hi Axel
> Many thanks for the new version. I will let you know if there are any problems.
> One thing I have noticed before is that some icons do not show up. Instead the
> icon for the folder disappears leaving a blank space
> Attached is a copy of one icon which behaves like this.

the icon is 128x128 pixels, and I currently do not resize the icons but display
the top left portion (16x16 pixels). In this case that area of the image is all
transparent pixels that's why you do not see anything.

> This change to Quick Folders has made it incompatible with the Colour Folders
> add on but that is not surprising as they both address the same area.

Well actually it is not incompatible they both work at the same time. Just QF's
rule adding the icon is "stronger" and overrides the colored icon from the
Color Folders extension. As soon as you remove the QuickFolders Icon, the
colored icon will come back. I specifically allow using both extensions at the
same time (but do not recolor my own icons).

Also I still need to add a function for when you add a previously not
bookmarked folder that already has an icon assigned to the QuickFolders toolbar
- currently QF is not able to detect this, so you have to add the icon to the
QuickFolder tab separately. It works if the Tab already exists and you style
the folder from the folder tree.
------- Comment #14 From Axel Grude 2014-08-14 04:22:47 -------
Created an attachment (id=7910) [details]
3.15 prerelease 316

Some features were improved in this version

 (1) Improved context menus for setting custom icon by hiding unnecessary items
based on folder's current icon status
 (2) Icon will now be added automatically if foldertree had a custom icon and
is dragged to create a new QF tab

First Last Prev Next    No search results available