First Last Prev Next    No search results available
Details
: Not working in Earlybird 25.0a2 (2013-08-14)
Bug#: 25536
: QuickFolders
: General
Status: RESOLVED
Resolution: FIXED
: PC
: Windows NT
: unspecified
: P2
: blocker
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Shari Smith <webweaver64@gmail.com>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
3.12 prerelase 56 (472.61 KB, application/x-xpinstall)
2013-08-15 13:16, Axel Grude
no flags Details
3.12 Prerelase 96 (483.78 KB, application/x-xpinstall)
2013-09-02 02:16, Axel Grude
no flags Details
3.12 Prerelase 103 (483.82 KB, application/x-xpinstall)
2013-09-02 06:50, Axel Grude
no flags Details
prerelease 103 - rendering issue (457.67 KB, image/jpeg)
2013-09-02 09:22, helkav
no flags Details
3.12 Prerelase 110 (484.76 KB, application/x-xpinstall)
2013-09-02 13:50, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2013-08-15 12:07
When updated all tabs were gone, and I'm unable to add them again.
I tried to find version 3.3 which is listed on your site as the latest version
however it's not showing up anywhere.

I disabled all addons to double check it isn't working.
------- Comment #1 From Axel Grude 2013-08-15 13:15:05 -------
According to 

https://addons.mozilla.org/en-US/thunderbird/addon/quickfolders-tabbed-folders/

3.11 is the latest released version
------- Comment #2 From Axel Grude 2013-08-15 13:16:26 -------
Created an attachment (id=7653) [details]
3.12 prerelase 56

try this version - it might be a duplicate of [bug 25533]
------- Comment #3 From helkav 2013-08-20 02:31:11 -------
I had the same issue

I have downloaded the prerelease version indicated and tried it out in Aurora
26.0a1

It seems to be working fine...have just briefly tested it...I will keep testing
it over the next few days and report back...
------- Comment #4 From helkav 2013-09-02 01:41:27 -------
I downloaded the pre-release and that worked for a few daily updates and now it
doesn't work again.

This must be very frustrating for add-on developers. I strongly feel TB should
a minimum backward-compatibility so you don't keep having to re-write your
add-ons every time there's an update

I have gone back to EarlyBird for the moment, I will watch and see if another
pre-release comes out so I can go back to Daily
------- Comment #5 From Axel Grude 2013-09-02 02:16:03 -------
Created an attachment (id=7657) [details]
3.12 Prerelase 96

The latest prerelease. Works well with Tb 17.0.8 and Earlybird. Did not test on
daily.
------- Comment #6 From Axel Grude 2013-09-02 02:36:59 -------
(In reply to comment #4)
> I downloaded the pre-release and that worked for a few daily updates and now it
> doesn't work again.

try the new prerelease, if you get the same oriblem, please check tools > error
console. I highly recommend installing console2 and then disabling content
logging for more meaningful results.

> This must be very frustrating for add-on developers. I strongly feel TB should
> a minimum backward-compatibility so you don't keep having to re-write your
> add-ons every time there's an update.

it is not easy as there are constant improvements and cleanups in gecko's code
base, so as addons developers we have to stay "on the ball"!

> 
> I have gone back to EarlyBird for the moment, I will watch and see if another
> pre-release comes out so I can go back to Daily
> 

yeah, try pre96 I, have a feeling there is at least one Tb code-base related
fix that might help. Note: only most (but not all) locales are complete in this
version, so if you use Polish or Asian locales it might not work for you (You
would get missing entities errors). I have tried to find out which ones exactly
but babelzilla is currently unavailabe - the perks of being non-commercial ;-)

English and West-European versions should be fine.
------- Comment #7 From Axel Grude 2013-09-02 03:21:43 -------
(In reply to comment #6)
> (In reply to comment #4)
> > I downloaded the pre-release and that worked for a few daily updates and now it
> > doesn't work again.
> 
> try the new prerelease, if you get the same oriblem, please check tools > error
> console. I highly recommend installing console2 and then disabling content
> logging for more meaningful results.
> 
> > This must be very frustrating for add-on developers. I strongly feel TB should
> > a minimum backward-compatibility so you don't keep having to re-write your
> > add-ons every time there's an update.
> 
> it is not easy as there are constant improvements and cleanups in gecko's code
> base, so as addons developers we have to stay "on the ball"!
> 
I have just run it on a VM and I can reproduce the problem, seems a major one
(and it could just be a temporary bug in Thunderbird):

Error: ReferenceError: GetMsgFolderFromUri is not defined
Source file: chrome://quickfolders/content/quickfolders-model.js
Line: 170

if this is indeed the case that would pose a BIG problem for all addons that
deal with folders...

I have sent a question to tb-planning, but this should really be reported as a
bug to Thunderbird core, as that is potentially a huge problem. The other
recent breakage by converting nsIMsgAccount from nsIMutableArray to nsIArray
was relatively easy to fix but raises soem obvious concerns on how these
changes are published to the Addon Developers community.
------- Comment #8 From Axel Grude 2013-09-02 06:50:57 -------
Created an attachment (id=7658) [details]
3.12 Prerelase 103

After some back and forth with the #maildev list it surfaced that widgetglue.js
had been gotten rid off. I can potentially imagine that this will affect quite
a big amount of Addons, so I think raising a bug on this is in order.

I also had to rewrite portions of code for quickFilters and of course branch
out the code for Postbox as it did not have the module "MailUtils.js" which has
the missing mail folder function.

Tested in 
Tb 17.0.8, Tb 24.0, Tb 3.1.20 and Tb 26.0a1 (2013-09-02) 
Postbox 3.0.8
SeaMonkey 2.19
------- Comment #9 From helkav 2013-09-02 09:22:48 -------
Created an attachment (id=7659) [details]
prerelease 103 - rendering issue

I have just retested with the latest pre-release 103 as suggested, and although
the folders have been restored, there is a rendering issue: see attached file

this update of Daily has JUST fixed a bug # 909136 I previously reported with
rendering, which seems too much of a coincidence for me

Daily version 26.0a1 (2013-09-02)
------- Comment #10 From Axel Grude 2013-09-02 09:28:41 -------
(In reply to comment #9)
> Created an attachment (id=7659) [details] [details]
> prerelease 103 - rendering issue
> 
> I have just retested with the latest pre-release 103 as suggested, and although
> the folders have been restored, there is a rendering issue: see attached file
> 
> this update of Daily has JUST fixed a bug # 909136 I previously reported with
> rendering, which seems too much of a coincidence for me
> 
> Daily version 26.0a1 (2013-09-02)
> 


Before you change anything, can you make a screenshot of the "bling my tabs"
settings please?

Just set a different standard tab color and you should be good to go. There was
some fundamental changes in tab coloring, and the translation from the old
colors to the new ones seems to be not quite up to par yet.
------- Comment #11 From helkav 2013-09-02 09:46:39 -------
I have just retested with the latest pre-release 103 as suggested, and although
the folders have been restored, there is a rendering issue:see attached file

(In reply to comment #10)
> (In reply to comment #9)
> > Created an attachment (id=7659) [details] [details] [details]
> > prerelease 103 - rendering issue
> > 
> > I have just retested with the latest pre-release 103 as suggested, and although
> > the folders have been restored, there is a rendering issue: see attached file
> > 
> > this update of Daily has JUST fixed a bug # 909136 I previously reported with
> > rendering, which seems too much of a coincidence for me
> > 
> > Daily version 26.0a1 (2013-09-02)
> > 
> 
> 
> Before you change anything, can you make a screenshot of the "bling my tabs"
> settings please?
> 
> Just set a different standard tab color and you should be good to go. There was
> some fundamental changes in tab coloring, and the translation from the old
> colors to the new ones seems to be not quite up to par yet.
> 

ah yes that sorted it, so obviously no biggie then. there is a seperate issue
with TB itself where if I increase font size some dialogs are too 'long' but
without a scrollbar I have to guess what's at the bottom. I'm just passing this
on because there's no point me attaching the screenshot you want. 

just to confirm changing my standard tab colour back to white sorted the issue-
should have been obvious really!
------- Comment #12 From Axel Grude 2013-09-02 10:03:15 -------
(In reply to comment #11)
> I have just retested with the latest pre-release 103 as suggested, and although
> the folders have been restored, there is a rendering issue:see attached file
> 
> (In reply to comment #10)
> > 
> > Before you change anything, can you make a screenshot of the "bling my tabs"
> > settings please?
> > 
> > Just set a different standard tab color and you should be good to go. There was
> > some fundamental changes in tab coloring, and the translation from the old
> > colors to the new ones seems to be not quite up to par yet.
> > 
> 
> ah yes that sorted it, so obviously no biggie then. there is a seperate issue
> with TB itself where if I increase font size some dialogs are too 'long' but
> without a scrollbar I have to guess what's at the bottom. I'm just passing this
> on because there's no point me attaching the screenshot you want. 
> 
> just to confirm changing my standard tab colour back to white sorted the issue-
> should have been obvious really!
> 

It would have been interesting to know what your previous color choice for
Standard tabs was as I don't really want the same to happen to the other 24,000
users :-)

Note: You have a lot of Virtual Tabs. Do you ever experience performance issues
with these?
------- Comment #13 From Axel Grude 2013-09-02 13:50:22 -------
Created an attachment (id=7660) [details]
3.12 Prerelase 110

I had a major re-think of the coloring system and create an "import" routine
for pre 3.12 installations. More importantly, I came to the conclusion, that I
actually need 5 palette types instead of 4. Hope it is clear from the "Bling my
Tabs" options page.
------- Comment #14 From helkav 2013-09-03 01:45:34 -------
(In reply to comment #13)
> Created an attachment (id=7660) [details] [details]
> 3.12 Prerelase 110
> 
> I had a major re-think of the coloring system and create an "import" routine
> for pre 3.12 installations. More importantly, I came to the conclusion, that I
> actually need 5 palette types instead of 4. Hope it is clear from the "Bling my
> Tabs" options page.
> 

(In reply to comment #12)
> (In reply to comment #11)
> > I have just retested with the latest pre-release 103 as suggested, and although
> > the folders have been restored, there is a rendering issue:see attached file
> > 
> > (In reply to comment #10)
> > > 
> > > Before you change anything, can you make a screenshot of the "bling my tabs"
> > > settings please?
> > > 
> > > Just set a different standard tab color and you should be good to go. There was
> > > some fundamental changes in tab coloring, and the translation from the old
> > > colors to the new ones seems to be not quite up to par yet.
> > > 
> > 
> > ah yes that sorted it, so obviously no biggie then. there is a seperate issue
> > with TB itself where if I increase font size some dialogs are too 'long' but
> > without a scrollbar I have to guess what's at the bottom. I'm just passing this
> > on because there's no point me attaching the screenshot you want. 
> > 
> > just to confirm changing my standard tab colour back to white sorted the issue-
> > should have been obvious really!
> > 
> 
> It would have been interesting to know what your previous color choice for
> Standard tabs was as I don't really want the same to happen to the other 24,000
> users :-)
> 
> Note: You have a lot of Virtual Tabs. Do you ever experience performance issues
> with these?
> 

I do have several virtual tabs (I presume you mean tabs created from virtual
folders?) I don't know how you could see that, but no I haven't noticed any
performance issues to do with quickfolders. The combination of virtual folders
and quickfolders helps me keep my TB manageable. 

The only issue is that mark folder read on a virtual quickfolder tab (phew)
doesn't work correctly. it takes the unread indicator from the label but the
unread mails still remain unread

P.S. I think my tab colour was white before I upgraded last time, when I went
in it had changed to navy/black
------- Comment #15 From Axel Grude 2013-09-03 03:37:51 -------
(In reply to comment #14)
> (In reply to comment #13)
> > Note: You have a lot of Virtual Tabs. Do you ever experience performance issues
> > with these?
> > 
> 
> I do have several virtual tabs (I presume you mean tabs created from virtual
> folders?) I don't know how you could see that, 

I am psychic! ;)

Actually the icons were a good a giveaway.

> I haven't noticed any
> performance issues to do with quickfolders. The combination of virtual folders
> and quickfolders helps me keep my TB manageable. 

cool. Another nice use case.

> 
> The only issue is that mark folder read on a virtual quickfolder tab (phew)
> doesn't work correctly. it takes the unread indicator from the label but the
> unread mails still remain unread

This might be Thunderbird bug but feel free to file a separate bug here. Who
knows maybe it can be fixed for the 3.12 release, there is still a bit of
function creep:

http://quickfolders.mozdev.org/version.html#3.12

> 
> P.S. I think my tab colour was white before I upgraded last time, when I went
> in it had changed to navy/black
> 

Okay, I think I got the upgrade covered quite well in code. Need to run some
more tests on fresh profiles though.
------- Comment #16 From helkav 2013-09-03 03:50:07 -------
ok please let me know of any testing I can help with

I currently keep latest releases of Daily / Early / TB on my system : Win 7
64bit

however I also have a linux / win xp dual boot on an old laptop (haven't
installed TB on those yet, but have been meaning to)

so any of those systems / configs you need specific tests on, just let me know

I have to be honest I haven't donated yet (and this is an add-on worthy of it)
as I have already gone over my software budget for this year...but maybe this
way I can donate in time instead for the moment
------- Comment #17 From Axel Grude 2013-09-03 04:04:47 -------
(In reply to comment #16)
> ok please let me know of any testing I can help with
> 
> I currently keep latest releases of Daily / Early / TB on my system : Win 7
> 64bit however I also have a linux / win xp dual boot on an old laptop (haven't
> installed TB on those yet, but have been meaning to)
> 
> so any of those systems / configs you need specific tests on, just let me know

okay we will see - I am using the free virtualbox and have an XP and a Ubuntu
virtual machine, both of which are running constantly running out of space (I
partitioned too small).


> I have to be honest I haven't donated yet (and this is an add-on worthy of it)
> as I have already gone over my software budget for this year...but maybe this
> way I can donate in time instead for the moment

Don't worry :) bug filing is also very valuable. If you want to do something
good for me leave a 5star reply, and as always, recommend my addons!
------- Comment #18 From helkav 2013-09-03 04:22:33 -------
BTW re the virtual folders "mark as read" - that option is simply not available
in TB daily (not in the context menu anyway, and I can't see anywhere else it
would be) so perhaps it's best to just disable it on a quickfolders virtual tab
until/if it becomes available in TB?
------- Comment #19 From Axel Grude 2013-09-03 07:52:24 -------
(In reply to comment #18)
> BTW re the virtual folders "mark as read" - that option is simply not available
> in TB daily (not in the context menu anyway, and I can't see anywhere else it
> would be) so perhaps it's best to just disable it on a quickfolders virtual tab
> until/if it becomes available in TB?
> 

good idea. should be possible....
------- Comment #20 From Tony Mechelynck 2013-09-03 21:28:39 -------
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5

I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
is QF 3.12pre56. So:
- How useful would it be to upgrade? (44 patchlevels are enough to give me
pause)
- Is there a central place which can be checked at any time for the latest
bleeding-edge development version of QuickFolders? (and yes, I know that
bleeding-edge versions are less stable than release versions, but I'm OK with
that, because OTOH by using those same bleeding-edge versions and testing them
in all possible ways one has a better chance to find and fix bugs early, before
they bite the general public).

And --- sorry for the bugspam. ;-/
------- Comment #21 From helkav 2013-09-04 01:18:10 -------
(In reply to comment #20)
> Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5
> 
> I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
> is QF 3.12pre56. So:
> - How useful would it be to upgrade? (44 patchlevels are enough to give me
> pause)
> - Is there a central place which can be checked at any time for the latest
> bleeding-edge development version of QuickFolders? (and yes, I know that
> bleeding-edge versions are less stable than release versions, but I'm OK with
> that, because OTOH by using those same bleeding-edge versions and testing them
> in all possible ways one has a better chance to find and fix bugs early, before
> they bite the general public).
> 
> And --- sorry for the bugspam. ;-/
> 

Hope I'm not jumping in incorrectly here (I'm not the dev!) but I have the
latest pre-release installed because I have TB daily & EarlyBird. You may not
need it with TB release, I'm not sure.

If you're nervous about it you could keep a seperate profile for TB release and
that way have the release add-on to go with TB release, and the pre-release
add-on to go with Daily or EarlyBird. Personally I find it easy enough to roll
back anyway so I don't worry about it.
------- Comment #22 From Tony Mechelynck 2013-09-04 03:47:22 -------
(In reply to comment #21)
> (In reply to comment #20)
> > Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> > SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5
> > 
> > I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
> > is QF 3.12pre56. So:
> > - How useful would it be to upgrade? (44 patchlevels are enough to give me
> > pause)
> > - Is there a central place which can be checked at any time for the latest
> > bleeding-edge development version of QuickFolders? (and yes, I know that
> > bleeding-edge versions are less stable than release versions, but I'm OK with
> > that, because OTOH by using those same bleeding-edge versions and testing them
> > in all possible ways one has a better chance to find and fix bugs early, before
> > they bite the general public).
> > 
> > And --- sorry for the bugspam. ;-/
> > 
> 
> Hope I'm not jumping in incorrectly here (I'm not the dev!) but I have the
> latest pre-release installed because I have TB daily & EarlyBird. You may not
> need it with TB release, I'm not sure.
> 
> If you're nervous about it you could keep a seperate profile for TB release and
> that way have the release add-on to go with TB release, and the pre-release
> add-on to go with Daily or EarlyBird. Personally I find it easy enough to roll
> back anyway so I don't worry about it.
> 

As you could have seen from the top lines of my post I'm using a trunk build of
SeaMonkey, one whose MailNews component is approximately equivalent with
Thunderbird 26.0a1. In fact I use neither Aurora nor Beta nor Release, so I
don't need parallel profiles for different versions. The question is: could
there be known bugs in the version I'm using which were fixed in the, er, 54
patchlevels since then? (and I ought to have checked my math in comment #20.)
And is there some constant place, always the same, where I could go look every
day or two to see if a new patchlevel has been published?
------- Comment #23 From Axel Grude 2013-09-04 09:33:55 -------
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> > > SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5
> > > 
> > > I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
> > > is QF 3.12pre56. So:
> > > - How useful would it be to upgrade? (44 patchlevels are enough to give me
> > > pause)

probably more useful to me as I get some bug reports. A lot of the "late"
version numbers are caused by me updating translations or iteration on a bug,
so the variations are usually minimal. (And you see above that I mark obsolete
frequently)

I was thinking whether I should introduce an official beta channel which would
be useful 2-3 weeks before each release, but I have to look into the extra work
involved...

> > > - Is there a central place which can be checked at any time for the latest
> > > bleeding-edge development version of QuickFolders? 

http://quickfolders.mozdev.org/version.html#latest

I keep that updated as I develop. But I do not post versions here, only bug
links.

> 
> As you could have seen from the top lines of my post I'm using a trunk build of
> SeaMonkey, one whose MailNews component is approximately equivalent with
> Thunderbird 26.0a1. In fact I use neither Aurora nor Beta nor Release, so I
> don't need parallel profiles for different versions. The question is: could
> there be known bugs in the version I'm using which were fixed in the, er, 54
> patchlevels since then?

That is possible - they are probably not SeaMonkey specific. In fact we are in
one :0) the best place to consult on what was fixed:

http://quickfolders.mozdev.org/version.html#3.12

I do not add prerelease numbers here and actually reordered the list to be
non-chronological so it is a little tricky to determine what the most current
version is. I don't usually publish prereleases (only attach them to the bugs
they address) but I also never branch so higher version numbers are better. The
official place for official betas would be here:

http://downloads.mozdev.org/quickfolders/

...but to my shame I admit it wasn't updated in a LONG time. If it helps I can
put the latest prerelease there, but I don't promise this to be always updated.

> (and I ought to have checked my math in comment #20.)
> And is there some constant place, always the same, where I could go look every
> day or two to see if a new patchlevel has been published?
> 

I guess since you are following all my bugzilla bugs you are pretty much
informed of all my prereleases... 
------- Comment #24 From Tony Mechelynck 2013-09-04 15:07:09 -------
(In reply to comment #23)
> (In reply to comment #22)
> > (In reply to comment #21)
> > > (In reply to comment #20)
> > > > Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> > > > SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5
> > > > 
> > > > I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
> > > > is QF 3.12pre56. So:
> > > > - How useful would it be to upgrade? (44 patchlevels are enough to give me
> > > > pause)
> 
> probably more useful to me as I get some bug reports.

OK, i'll do it then.

> A lot of the "late"
> version numbers are caused by me updating translations or iteration on a bug,
> so the variations are usually minimal. (And you see above that I mark obsolete
> frequently)
> 
> I was thinking whether I should introduce an official beta channel which would
> be useful 2-3 weeks before each release, but I have to look into the extra work
> involved...
> 
> > > > - Is there a central place which can be checked at any time for the latest
> > > > bleeding-edge development version of QuickFolders? 
> 
> http://quickfolders.mozdev.org/version.html#latest
> 
> I keep that updated as I develop. But I do not post versions here, only bug
> links.
> 
> > 
> > As you could have seen from the top lines of my post I'm using a trunk build of
> > SeaMonkey, one whose MailNews component is approximately equivalent with
> > Thunderbird 26.0a1. In fact I use neither Aurora nor Beta nor Release, so I
> > don't need parallel profiles for different versions. The question is: could
> > there be known bugs in the version I'm using which were fixed in the, er, 54
> > patchlevels since then?
> 
> That is possible - they are probably not SeaMonkey specific. In fact we are in
> one :0) the best place to consult on what was fixed:
> 
> http://quickfolders.mozdev.org/version.html#3.12
> 
> I do not add prerelease numbers here and actually reordered the list to be
> non-chronological so it is a little tricky to determine what the most current
> version is. I don't usually publish prereleases (only attach them to the bugs
> they address) but I also never branch so higher version numbers are better. The
> official place for official betas would be here:
> 
> http://downloads.mozdev.org/quickfolders/

In fact, I did check that before posting comment #20, but I saw only old stuff
there.

> 
> ...but to my shame I admit it wasn't updated in a LONG time. If it helps I can
> put the latest prerelease there, but I don't promise this to be always updated.
> 
> > (and I ought to have checked my math in comment #20.)
> > And is there some constant place, always the same, where I could go look every
> > day or two to see if a new patchlevel has been published?
> > 
> 
> I guess since you are following all my bugzilla bugs you are pretty much
> informed of all my prereleases... 
> 

:-) I would have followed the QuickFolders QA Contact, especially a dummy one
as used at BMO, or else watched the QuickFolders::General Component (which
comes out to the same thing), if the Mozdev version of Bugzilla allowed it. But
they haven't updated their Bugzilla in years, and it doesn't; so I watch the
default assignee (you) instead, and mark as read without reading when I get
bugmail for quickFilters, smarttemplate4, etc., which are not installed here.

As a SeaMonkey triager, I follow SeaMonkey::General at AMO, and then I found
out that it was useful to watch some components of SeaMonkey, MailNews Core,
Toolkit and Other Applications which often get new bugs "that interest me". So
I'm doing the same at Mozdev. :-)
------- Comment #25 From Axel Grude 2013-09-05 14:53:11 -------
(In reply to comment #24)
> (In reply to comment #23)
> > (In reply to comment #22)
> > > (In reply to comment #21)
> > > > (In reply to comment #20)
> > > > > Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> > > > > SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5
> > > > > 
> > > > > I see attached to this bug an XPI labeled "QF 3.12pre110". What I am using now
> > > > > is QF 3.12pre56. So:
> > > > > - How useful would it be to upgrade? (44 patchlevels are enough to give me
> > > > > pause)
> > 
> > probably more useful to me as I get some bug reports.
> 
> OK, i'll do it then.
> 
Okay,  to make that whole thing a little more significant, I uploaded my first
"beta" version today. Once it is reviewed by AMO, you can downloaded QF
3.12beta1 from the bottom of the QuickFolders AMO page. You will then
automatically be upgraded to the next beta (or release) and stay on the beta
channel until you decide to (manually) install a normal release version. This
way I can push out important milestones to a select crowd of users without
having to alert everybody of all my prereleases all the time.

So just head on over to
https://addons.mozilla.org/en-US/thunderbird/addon/quickfolders-tabbed-folders/
and scroll down to the bottom, hit development channel and click on the
download button.
------- Comment #26 From Tony Mechelynck 2013-09-05 18:40:30 -------
(In reply to comment #25)
[...]
> So just head on over to
> https://addons.mozilla.org/en-US/thunderbird/addon/quickfolders-tabbed-folders/
> and scroll down to the bottom, hit development channel and click on the
> download button.
> 

Or rather, for me it is
https://addons.mozilla.org/en-US/seamonkey/addon/quickfolders-tabbed-folders/

:-)

First Last Prev Next    No search results available