First Last Prev Next    No search results available
Details
: 0.9.1 regression: blank line is added before Reply template
Bug#: 25084
: smarttemplate4
: General
Status: RESOLVED
Resolution: FIXED
: PC
: Windows 7
: unspecified
: P1
: major
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Shawn Lipscomb <Shawn.Lipscomb@EWRInc.com>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
prerelease 2 (245.66 KB, application/x-xpinstall)
2012-08-18 04:58, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2012-08-16 11:32
My "Reply" template generates a blank line before my actual template text. The
template contains only:

%from(firstname)%,

with no blank lines before or after.  This did not occur in the previous
version.
------- Comment #1 From Micron Gust 2012-08-16 14:18:34 -------
I am also experiencing the same bug. Version 0.9.1 adds a blank line to the top
of every message, regardless of whether it's a reply, a forward, or a new
message.
------- Comment #2 From Frank VB 2012-08-18 02:39:48 -------
Version 0.9.1 adds a blank line to the top of every message.
Very annoying.
Please fix it quickly.
Frank
------- Comment #3 From Axel Grude 2012-08-18 04:58:23 -------
Created an attachment (id=7335) [details]
prerelease 2

This should fix the annoyance. The new global setting

extensions.smartTemplate4.insertBRatTop

controls this and is set to false (so no new line gets inserted) by default
------- Comment #4 From Axel Grude 2012-08-20 02:05:35 -------
Ok, this fix seems to work for others as well. Closing.
------- Comment #5 From DH 2012-10-03 10:38:54 -------
Please pardon the comment on a closed issue, but I tried the fix and it didn't
work. Perhaps I'm doing something wrong, but I opened about:config, added a
boolean named "extensions.smartTemplate4.insertBRatTop" because it didn't
exist, and set it to false. Restarted, and confirmed setting exists in false
state, and all emails using template plugin templates still have a space before
the template content. Did I do something wrong with this fix? I'm using TB 14.0
and SmartTemplate4 0.9.1. Thank you.
------- Comment #6 From Axel Grude 2012-10-03 15:47:57 -------
(In reply to comment #5)
> Please pardon the comment on a closed issue, but I tried the fix and it didn't
> work. Perhaps I'm doing something wrong, but I opened about:config, added a
> boolean named "extensions.smartTemplate4.insertBRatTop" because it didn't
> exist, and set it to false. Restarted, and confirmed setting exists in false
> state, and all emails using template plugin templates still have a space before
> the template content. Did I do something wrong with this fix? I'm using TB 14.0
> and SmartTemplate4 0.9.1. Thank you.
> 

You should probably try the fix I posted in comment#3:
https://www.mozdev.org/bugs/attachment.cgi?id=7335

then the setting will be added by the provided default.
------- Comment #7 From DH 2012-10-03 16:07:39 -------
Thank you! That was my dumbness, pardon me. I didn't see the link to updated
xpi file. I thought the solution involved simply adding/modifying the config.
Thank you again.

First Last Prev Next    No search results available