First Last Prev Next    No search results available
Details
: Support Line Breaks to force multiple tab rows
Bug#: 23039
: QuickFolders
: General
Status: RESOLVED
Resolution: FIXED
: All
: All
: unspecified
: P2
: minor
: ---

:
:
:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Charlie <CLweb@comcast.net>
Assigned To: Axel Grude <axel.grude@gmail.com>
:

Attachments
3.12 prerelease 4 (460.89 KB, application/x-xpinstall)
2013-02-27 11:30, Axel Grude
no flags Details
prerelease 5 (bugfix) (460.91 KB, application/x-xpinstall)
2013-02-27 14:53, Axel Grude
no flags Details
3.12 prerelease 7 (463.62 KB, application/x-xpinstall)
2013-02-28 01:43, Axel Grude
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2010-07-21 09:13
Multiple rows of tabs could be used to even greater organizational advantage if
the user could manually "insert row breaks."

   This could be implemented with various interfaces, whatever makes the coding
easiest.  For example, each tab could have a toggled property "Start new row
with this tab" and/or "Start new row after this tab."  Or, a more graphical
interface could be to right-click the space between tabs and add "Insert/remove
row break here" to the drop-down QF menu that appears.  I realize it would be
more complicated if the data structure doesn't actually store the row
breakpoints.

   This would better preserve the two-dimensional array of tabs when there are
insertions, deletions, reordering, or changes of name length, and thus the
screen position of any particular familiar tab.

   There would still be automatic insertion of row breaks if the user tries to
create a row wider than the window.   Combined with manual breaks, this could
produce "short rows" if a manual break closely follows an automatic break, but
I don't think that's so bad if the rows are meaningful to the user.

   Not a high priority, but would be nice to have.
------- Comment #1 From Axel Grude 2010-07-21 12:26:35 -------
Interesting thought; You can already add extra space to designated Folders,
there is a tweak here:
http://quickfolders.mozdev.org/faq_tips.html#Spacing

I think a similar rule for a inserting a line break _before_ a QuickFolder
could be invented...

I have tried now for 25 minutes but it always ends up on its own in a new line.
I have tried these ones, so far:

#QuickFolders-Toolbar.toolbar-flat toolbarbutton[label^="QF-bugs"]
 { position: absolute; left:0; }

#QuickFolders-Toolbar.toolbar-flat toolbarbutton[label^="QF-bugs"]
 { float: left; clear: left !important;}

#QuickFolders-Toolbar.toolbar-flat toolbarbutton[label^="QF-bugs"]:before
 { content: "<br>";}

#QuickFolders-Toolbar.toolbar-flat toolbarbutton[label^="QF-bugs"] 
 { display:inline-block; float:left; clear:left !important; }

no luck so far :(
------- Comment #2 From Axel Grude 2013-02-27 11:30:36 -------
Created an attachment (id=7537) [details]
3.12 prerelease 4

Experimental test version. Has a hardcoded English menu item for inserting /
removing a line break before the selected tab. I the tab is the first in the
category, the line break will still be inserted.
------- Comment #3 From Axel Grude 2013-02-27 14:53:52 -------
Created an attachment (id=7538) [details]
prerelease 5 (bugfix)

A bug was caused by current folder button, this fixes that.
------- Comment #4 From Axel Grude 2013-02-28 01:43:22 -------
Created an attachment (id=7539) [details]
3.12 prerelease 7

I added proper wordings depending on status:

↲ Insert Line break
↲ Remove Line break

I also created some context  sensitive icons, based on Yusuke Kamiyamane's
fugue icon set (Creative Commons) - see: http://p.yusukekamiyamane.com/
------- Comment #5 From Axel Grude 2013-02-28 01:44:19 -------
(From update of attachment 7538 [details])
prerelease 5 made obsolete by prerelease 7
------- Comment #6 From Axel Grude 2013-03-03 01:13:14 -------
Please also see [bug 24431] which uses the same mechanism for adding Separators

First Last Prev Next    No search results available